martes, 15 de noviembre de 2016

Función DESREF y función INDICE

Puede descargar el archivo:

Hoja1

Disponemos de una tabla de doble entrada con valores de ventas en cinco ciudades durante seis meses.

Partiendo de los datos anteriores, deseamos elaborar una tabla donde figure la ciudad, el mes y las ventas correspondientes.

En la celda L5 utilizamos la siguiente fórmula.

=INDICE($C$7:$H$11;COINCIDIR(J5;$B$7:$B$11;0);COINCIDIR(K5;$C$6:$H$6;0))

Ahora deseamos elaborar una tabla donde figuren las ventas máxima indicando en que ciudad y mes se alcanzaron.

La celda O5 es la siguiente.

=DESREF(L4;COINCIDIR(MAX(Ventas);Ventas;0);-2)

Hoja2

Planteamos un ejercicio para practicar el uso de DESREF y de INDICE.

Como datos nos proporcionan las averías que se producen en cada mes desde enero-2017 hasta diciembre-2025.
Nos piden que con Formato condicional marquemos la cifra de averías máximas y mínimas.

Queremos elaborar una tabla como la siguiente, donde se indiquen las averías máximas y mínimas y en que año y mes se producen, usando para el año y el mes la función DESREF.


Nos proporcionan el gráfico de la evolución de las averías a lo largo del tiempo.


Nos piden que volcar la base de datos anterior a una tabla de doble entrada, usando para ello la función INDICE.



Finalmente nos piden que partiendo de la tabla de doble entrada anterior construyamos una tabla igual a la que se utilizó inicialmente con los datos de partida. Para ello, volveremos a utilizar la función INDICE.

Hoja3

En esta hoja damos solución al ejercicio planteado en la hoja anterior.
La celda F9 nos proporciona el mes donde se alcanza el mínimo de averías, su fórmula es:

=DESREF($B$4;COINCIDIR(MIN(Averias);Averias;0);0)


Para elaborar esta tabla hemos realizado un cambio importante en la columna que recoge los meses. Inicialmente los meses venían en texto: ene, feb, mar, may, ... Lo que hemos hecho para que las fórmulas funcionen bien es cambiar esos textos por fechas reales con el formato que nos pide Excel para la fechas y luego con Formato de celda personalizado hemos pedido que se muestre únicamente el mes de esa fecha.


La celda Q5 que proporciona el primer número de averías (50.000) es la siguiente.

=INDICE(tabladoble;MES(P5);AÑO(P5)-2016)


No hay comentarios:

Publicar un comentario en la entrada