miércoles, 19 de marzo de 2014

Generar columnas de aleatorios

Descargue el fichero columnas_de_aleatorios.xlsm

Deseamos generar columnas con números aleatorios. Tantos números aleatorios como se indique.

En la zona amarilla (B2:K2) disponemos de 10 números  con valores que van entre 1 y 20. La idea es generar debajo de cada celda amarilla tantos números aleatorios, con la función =ALEATORIO(), como indique el número. Así por ejemplo, si en la celda amarilla figura un 4 debajo queremos que se generen 4 números aleatorios.


El la celda B3 se ha de escribir la siguiente fórmula.

=SI($A2<=B$1;ALEATORIO();"")

Esta fórmula escribe un aleatorio en la celda si el valor de su fila (celda azul) es menor o igual a valor indicado en la celda amarilla correspondiente. En caso contrario escribe "" que son dos dobles comillas seguidas, con nada dentro. Esto equivale a celda vacía.

Con esto generaríamos la tabla de la izquierda. Luego hemos creado una macro denominada "Copia Valores" con un botón para lanzarla que lo que hace es copiar y pegar valores en la tabla de la derecha con el objeto de que queden números (sin fórmulas) ya que previsiblemente esto es lo que deseamos.





jueves, 20 de febrero de 2014

Simulación del número de pasajeros

Puede descargar el archivo: simulapasajeros.xlsx


sábado, 12 de octubre de 2013

Ordenar un millón de valores

Descargue el fichero: Ordena_un_millon.xlsm

Podemos ordenar un millón de valores numéricos con VBA en un tiempo bastante aceptable.

En mi portatil (i7, 8Gb RAM) cada una de las dos macros tarda 2 segundos aproximadamente.


Sub genera_aleatorios_en_columna_A()
Dim i As Long
Dim R As Range
Dim A
Set R = Range("A1:A1000000")
A = R
Randomize
For i = 1 To 1000000
   A(i, 1) = Rnd
Next i
Range("A1:A1000000") = A
End Sub

Sub ordena_columna_A()
Columns("A:A").Sort key1:=Range("A1"), _
      order1:=xlAscending, Header:=xlNo
End Sub

lunes, 16 de septiembre de 2013

Ventas del periodo

Vamos a resolver un caso práctico.

Se trata de determinar las ventas del periodo para un cliente concreto.




Puede descargar el fichero aquí: caso_ventasperiodo.xlsx

miércoles, 4 de septiembre de 2013

Rellenar Series

Veremos  varias formas de rellenar Series, tanto manualmente como utilizando los iconos de Excel.

Series lineales, geométricas, cronológicas y de autorrelleno.

También veremos como acumular. Realizaremos el acumulado de una columna.




En la segunda parte del vídeo se ven aspectos más avanzados. Estableceremos una tendencia con valores no periódicos y se comprueba que los resultados obtenidos se ajustan a una recta de regresión. Se utiliza la función PRONOSTICO.



Este contenido pertenece al Curso de Excel Avanzado que se imparte en MiriadaX.