jueves, 15 de octubre de 2009

Nueva función SUMAR.SI.CONJUNTO

Descargar el fichero: sumarsiconjunto.xlsx

Excel 2007 incorpora la función =SUMAR.SI.CONJUNTO que permite una suma condicional en base a varios criterios. Es similar a la función SUMAR.SI, pero en el caso de la nueva función se pueden utilizar hasta 127 nuevos criterios simultáneamente.

=SUMAR.SI.CONJUNTO(rango_suma; rango_criterios1; criterios1; [rango_criterios2; criterios2]; …)


El orden de los argumentos no es similar al de la función SUMAR.SI, por lo que se ha de tener cuidado si se reutiliza la fórmula antigua para introducir nuevos criterios.

Veamos un caso práctico donde pretendemos determinar el importe comprometido en avales en el día de hoy. Disponemos de 25 proyectos de inversión o de ejecución de obra. Por cada proyecto pueden existir tres tipos de avales (A, B y C), y por cada uno de ellos existe una fecha de inicio, una fecha de finalización del aval y su importe. Puesto que cada día varía la fecha actual, se ha de recalcular diariamente.




La fórmula aplicada en I4 es:

=SUMAR.SI.CONJUNTO(E14:E38;C14:C38;"<="&B8;D14:D38;">="&B8)


Utilizamos un pequeño truco para indicar los criterios. En lugar de escribir para el critrerio 1 que "<=B8", hemos tenido que escribir "<="&B8. Se ha de utilizar el concatenador & para que funcione.

8 comentarios:

  1. HOLA. PARA LA DESCARGA DEL FICHERO NO ESTÁ FUNCIONANDO, NI DANDOLE GUARDAR Y LUEGO DESCOMPRIMIENDO, NI DANDOLE ABRIR, A VER QUE SERÁ. GRACIAS POR TUS APORTES. MI DIRECCIÓN ES hvelandia32@hotmail.com

    ResponderEliminar
  2. Hola Hvelandia.

    Es posible que el problema esté en que es un fichero de la versión 2007 de Excel. Tiene extensión xlsx, en lugar de tener la extensión clásica xls.

    Si no tienes instalada la nueva versión de Office 2007, o el módulo de compatibilidad que proporciona gratuitamente Microsoft, al intentar abrir el fichero lo considera como un fichero comprimido y no te permite ver la hoja de cálculo.

    En el siguiente enlace puedes descargar el paquete de compatibilidad para Office 2007. Así podrás abrir el archivo, pero debes considerar que la función =SUMAR.SI.CONJUNTO únicamente está definida en la nueva versión 2007 de Excel.


    http://www.microsoft.com/downloads/details.aspx?displaylang=es&familyid=941B3470-3AE9-4AEE-8F43-C6BB74CD1466

    O simplemente escribe en Google las palabras:

    compatibilidad office 2007

    Un cordial saludo.

    Adolfo Aparicio

    ResponderEliminar
  3. hello... hapi blogging... have a nice day! just visiting here....

    ResponderEliminar
  4. muchas gracias, por el aporte, esta muy bueno,

    ResponderEliminar
  5. Hola, estoy intentando sumar de una tabla con la función SUMAR.SI.CONJUNTO en la que hay en una fila fechas y en la siguiente cantidades.
    Necesito realizar la suma en función de un resultado que me da la fecha objetivo en una celda, procedente de un cálculo.
    Podría alguien decirme cómo hacerlo?
    Gracias de antemano

    ResponderEliminar
  6. Muchísimas gracias por el artículo. Me estaba volviendo loco para poder comparar fechas en Excel con esta función y hasta que no he visto lo del truquillo del "comodín" "&" no he podido hacer nada. Ha sido utilizarlo y solucionarse todos los problemas.

    Un cordial saludo.

    ResponderEliminar
  7. Hola
    Me colocaron este ejercicio en mi estudio pero no se como colocarlo me podria ayudar. Gracias
    Tengo la siguiente base de datos y necesito asignarles puntos por ventas de la siguiente manera.

    1si es panadero y cumple el objetivo dele 100 puntos pero si es vendedor dele 200
    2 si cumplio la condicion anterior y cumple el objetivo de los productos de aseo al panadero dele 300y al vendedor 400.

    empleado cargo objetivo resultado Prod…
    cadadda pastelero 7826 3462 aseo
    cadadda pastelero 2252 78965 aseo
    cadadda pastelero 78945 25254 cocina
    cadadda pastelero 26712 3462 cocina
    cadadda pastelero 2252 79223 cocina
    daniel vendedor 78965 26222 aseo
    daniel vendedor 25254 22582 aseo
    daniel vendedor 3462 258622 aseo
    daniel vendedor 79223 22582 cocina
    daniel vendedor 3462 35874 cocina
    sol pastelero 258622 25322 aseo
    sol pastelero 22582 12589 aseo
    sol pastelero 35874 25322 cocina
    sol pastelero 26222 22582 cocina
    sol pastelero 22582 22632 cocina
    sunny vendedor 12589 25586 aseo
    sunny vendedor 25322 50000 aseo
    sunny vendedor 22582 25622 aseo
    sunny vendedor 22632 25586 cocina
    sunny vendedor 25322 14256 cocina
    vamila vendedor 50000 26712 aseo
    vamila vendedor 25622 2252 aseo
    vamila vendedor 25586 7826 aseo
    vamila vendedor 14256 2252 cocina
    vamila vendedor 25586 78945 cocina
    hace 5 minutos - Quedan 4 días para responder

    ResponderEliminar
  8. Que tal, quiero hacer uso de esta función ya que según yo es la que debo usar, tengo un rango de suma digamos formas de pago y en la siguiente celda a que pertenecen representado con una letra, lo que quiero es que cuente lo que tengo atrás siempre y cuando tenga la letra correspondiente en el rango que le pido a la maquina, es posible o no me explico???

    ResponderEliminar